Double boot Linux Mint 18 avec Windows 10 sur Acer Aspire S5-371

Par Larry Ewing, Simon Budig, Anja Gerwinski
Par Larry Ewing, Simon Budig, Anja Gerwinski

Il est souvent difficile de trouver un tutoriel rapide et bien fait pour faire un double boot Linux/Windows sur une machine achetée dans le commerce où Windows est fourni préchargé et prépayé .

Comme d’habitude, et contrairement à ce que croient naïvement les juges, la machine ACER dont je viens de faire l’acquisition est spécialement configurée pour rendre l’installation d’un autre système d’exploitation impossible, en tout cas pour des consommateurs moyens n’étant pas spécialement avertis en informatique.

En effet, la Linux Mint 18 que je viens d’installer ne parvient pas à se charger au redémarrage après une installation tout à fait classique. C’est Windows 10 qui démarre systématiquement et c’est foncièrement agaçant !

En réalité, comme d’habitude, l’UEFI de la machine est verrouillé et il a fallu que je recherche sur internet une solution que je trouve pertinente.

Elle se trouve sur cette page. Il s’agissait d’un tutoriel pour Windows 7 et il est toujours valable pour Windows 10 avec une machine récente.

J’ai d’abord installé Mint et c’est ensuite que j’ai modifié les options de l’UEFI (accessible par la touche F2). Après ces modifications, Grub s’est lancé en proposant le choix Mint.

Mise à jour :

Notez qu’après mise à jour du noyau, vous serez peut-être comme moi obligé de renouveler cette opération. Les 3 sorties que j’avais à configurer (Grubx64.efi, shimx64.efi et MokManager.efi) sur le disque dur étaient toujours présentes, mais seule l’opération de renommage du premier argument, Grub, était possible (les autres m’indiquant que le fichier n’était pas présent). Le renommage du premier en « linuxgrubx64efi » a été suffisant pour fonctionner.

Notez également qu’au cours de ces manipulations de l’EFI, j’ai pu désactiver le Secure Boot tout en conservant le mode de démarrage EFI. En l’état, tout fonctionne.

Le Wifi était aussi problématique. Le matériel est un chipset Atheros QCA6174 et aucune détection de réseau n’était possible. Pour résoudre le problème, j’ai installé le paquet linux-firmware.

sudo apt-get install linux-firmware

La solution est disponible sur le forum Linux Mint :

Voilà une machine totalement fonctionnelle !

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *