Installation de la clé de sécurité RPVA pour Kubuntu 16.04 LTS

clerpvaQuelques lignes pour vous décrire l’installation « du RPVA » à partir d’une installation « propre » de Kubuntu 16.04 LTS.

Le tutoriel n’a pas fondamentalement changé avec l’ancienne clé, mis à part qu’il est devenu inutile de configurer les routes avec le Cloud des avocats mis en place par le CNB.

Cela vous permet de rendre le boîtier Navista et de faire ainsi quelques économies.

Je remercie mon confrère Antoine BON qui, dans notre groupe d’avocats sous Linux (Google groupe) qui nous a conçu le tutoriel avec la nouvelle clé.


 

1. La clé de sécurité

1.1 L’ancienne clé.

1.1.1. Les paquets nécessaires

Les utilitaires initialement requis (pcsc-tools) et pcscd sont complétés par libpcsc-perl. L’installation se fait via sudo  :

 ~$ sudo apt-get install pcsc-tools pcscd libpcsc-perl
 The following additional packages will be installed:
 [...]
 Souhaitez-vous continuer ? [O/n]

Répondre par oui.

~$ sudo pcsc_scan

La clé si elle est reconnue doit être listée dans le retour de commande.

Installer le driver Gemalto (libclassicclient). Celui-ci nécessite une dépendance plus ancienne que la version actuellement disponible dans les distributions GNU/Linux ; Il s’agit donc d’une faille de sécurité qui n’a pas été corrigée par Gemalto à ce jour, ce qui est très regrettable :

Télécharger ces 2 paquets logiciels et les installer avec Gdebi dans l’ordre que j’indique (d’abord libssl, puis libclassicclient, sinon l’installation n’est pas possible).

1.1.2. Le chargement du module (la clé USB) dans Firefox

Rendez-vous dans : préférences > avancé > certificats > périphériques de sécurité.

Cliquez sur « charger » pour pouvoir chercher la librairie libgclib.so

Elle se trouve dans à cet endroit : /usr/lib/classicclient/libgclib.so

Validez et redémarrez Firefox.

Rendez-vous sur le site : https://connexion.avocat.fr (sans boîtier Navista qui ne vous sert plus à rien).

1.2 La nouvelle clé.

1.2.1. Les paquets nécessaires

La nouvelle est une IDGO 800 qui nécessite de nouveaux drivers que vous trouverez ici. Ils ne sont fournis que pour Ubuntu 14.04

Pour Ubuntu 16.04, il faut installer toute une série de dépendances.

  • libboost-filesystem1.54.0_1.54.0-4ubuntu3_amd64.deb
  • libboost-serialization1.54.0_1.54.0-4ubuntu3_amd64.deb
  • libboost-system1.54.0_1.54.0-4ubuntu3_amd64.deb
  • libboost-thread1.54.0_1.54.0-4ubuntu3_amd64.deb
  • libwxbase3.0-0_3.0.0-2_amd64.deb
  • libwxgtk3.0-0_3.0.0-2_amd64.deb

Elles se trouvent sur http://packages.ubuntu.com/ et s’installent avec le logiciel Gdebi.

1.2.2. Le chargement du module (la clé USB) dans Firefox

Pour le chargement du module (token) dans Firefox, le chemin pour les anciennes clés est :

/usr/lib/ClassicClient/libgclib.so

Pour le chargement du nouveau module (token) dans Firefox, le chemin a changé.
/usr/lib/libidprimepkcs11.so
ou
/usr/lib/pkcs11/libidprimepkcs11.so

2. Les certificats de sécurité

Firefox est obligatoire car il gères les périphériques physiques de sécurité.

Cliquez sur les liens ci-dessous et validez tous les choix proposés :

Téléchargez les certificats dans votre ordinateur :

Puis, depuis le gestionnaire de certificats de Firefiox, importer les certificats que vous venez de télécharger.

Voilà 🙂

 

5 réponses à “Installation de la clé de sécurité RPVA pour Kubuntu 16.04 LTS

  1. Le tuto marche bien sur Ubuntu 16.04.

    Cependant quand j’ai reçu la clef, elle n’avait pas un PIN pré-activé. Il a fallu que je l’active et définisse son code en utilisant un .exe sous windows à télécharger sur le site de certeurope.

    Je n’ai pas essayé par des outils linux comme classicclient, si quelqu’un pouvait tester et faire un retour ce serait bien. Sinon il faudra utiliser l’ordinateur sous windows d’un confrère ou de l’ordre pour activer la clef (cela prend 5 minutes).

    1. C’est une honte de devoir passer par un ordinateur sous windows pour charger un code pin alors que tout est fonctionnel sous linux…. décidément, le CNB et l’informatique, c’est vraiment une honte.

  2. Pour les confrères qui souhaitent utiliser le tutoriel ci-dessus, il est important de faire attention à remplacer « amd64 » par la bonne architecture de CPU le cas échéant (a priori ça pourrait être « i386 »). Pour être certain de votre architecture, tapez en ligne de commande « arch ».

    Le tutoriel doit fonctionner sur toute distribution Ubuntu, Kubuntu, Lubuntu, Ubuntu Gnome, Ubuntu Mate et Xubuntu.

    Le tutoriel fonctionne très bien avec une Debian 8 (peu importe l’interface graphique choisie). Vous pouvez me contacter à rboucq@gmail.com pour obtenir le paquet libclassicclient_6.1.0-b07_amd64.deb qui n’est plus sur les dépôts de Debian.

    Pour toutes autres distributions de Linux, il est important de rechercher les paquets par rapport au nom de ce dernier (éventuellement de sa version). Hormis pour le paquet précédent, toutes les versions ultérieures de paquet semblent fonctionner.

    Un grand merci à Antoine Bon et à Frédéric Cuif pour cette initiative de publication.

    1. Bonjour

      A priori, il faut utiliser le logiciel ‘alien’ pour convertir les paquets .deb en .rpm et, ensuite, les installer en suivant le guide ci-dessus. Normalement, ça devrait fonctionner.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *